re = /^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$/m
str = '1,2,3,4
A,B,C,D
10,11,12,13
10,AA,BB,CC
1,x
1
FF
FF,1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end