use strict;
my $str = '1,2,3,4
A,B,C,D
10,11,12,13
10,AA,BB,CC
1,x
1
FF
FF,1';
my $regex = qr/^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}