// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((.*)\/(.*)\/(.*) (.*):(.*):(.*)) (\[(error)\]) (\[(.*)\]) (([\t\n])?((?:[^\t\n]*[\t\n])+.*)|(.*))").unwrap();
let string = "2015/10/06 19:20:27 [error] [php] Trying to get property of non-object (/www/ussd/protected/components/Process.php:267)
Stack trace:
#0 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3570): CInlineAction->runWithParams()
#1 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3555): TestController->runAction()
#2 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3545): TestController->runActionWithFilters()
#3 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1746): TestController->run()
#4 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1666): CWebApplication->runController()
#5 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1191): CWebApplication->processRequest()
#6 /www/ussd/index.php(22): CWebApplication->run()
REQUEST_URI=/test/?dialog_id=32&ussd_text=*152%23&msisdn=995557231065&service_code=152";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}