#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((.*)\/(.*)\/(.*) (.*):(.*):(.*)) (\[(error)\]) (\[(.*)\]) (([\t\n])?((?:[^\t\n]*[\t\n])+.*)|(.*))"
Local $sString = "2015/10/06 19:20:27 [error] [php] Trying to get property of non-object (/www/ussd/protected/components/Process.php:267)" & @CRLF & _
"Stack trace:" & @CRLF & _
"#0 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3570): CInlineAction->runWithParams()" & @CRLF & _
"#1 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3555): TestController->runAction()" & @CRLF & _
"#2 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3545): TestController->runActionWithFilters()" & @CRLF & _
"#3 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1746): TestController->run()" & @CRLF & _
"#4 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1666): CWebApplication->runController()" & @CRLF & _
"#5 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1191): CWebApplication->processRequest()" & @CRLF & _
"#6 /www/ussd/index.php(22): CWebApplication->run()" & @CRLF & _
"REQUEST_URI=/test/?dialog_id=32&ussd_text=*152%23&msisdn=995557231065&service_code=152"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")