use strict;
my $str = '+55(91)3348-0276
559133480276
(91)3348-0276
9133480276
3348-0276
33480276
+55(91)98444-6776
5591984446776
(91)98444-6776
91984446776
98444-6776
984446776';
my $regex = qr/^(((\+?[0-9]{2})?\(?[0-9]{2}\)?)?([0-9]?[0-9]{4}\-?[0-9]{4}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}