package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((\+?[0-9]{2})?\(?[0-9]{2}\)?)?([0-9]?[0-9]{4}\-?[0-9]{4}))$`)
var str = `+55(91)3348-0276
559133480276
(91)3348-0276
9133480276
3348-0276
33480276
+55(91)98444-6776
5591984446776
(91)98444-6776
91984446776
98444-6776
984446776`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}