$re = '/\b((?!(?:.\B)*(?:\B.)*\1)[dog]+)\b/';
$str = 'dog
gos
aegihl;iaei
brog
go
god
dooooog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);