using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?!(?:.\B)*(?:\B.)*\1)[dog]+)\b";
string input = @"dog
gos
aegihl;iaei
brog
go
god
dooooog";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}