re = /^\((\d+)\)\s+([^\(]+)\(([^\)]+)\)\s+vs\.\s+\((\d+)\)\s+([^\(]+)(.*)$/
str = '(8) Cincinnati (22-10) vs. (9) Purdue (21-12)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end