const regex = /^\((\d+)\)\s+([^\(]+)\(([^\)]+)\)\s+vs\.\s+\((\d+)\)\s+([^\(]+)(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\((\\d+)\\)\\s+([^\\(]+)\\(([^\\)]+)\\)\\s+vs\\.\\s+\\((\\d+)\\)\\s+([^\\(]+)(.*)$', '')
const str = `(8) Cincinnati (22-10) vs. (9) Purdue (21-12)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}