# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((0|1)[0-9])\/([0-3][0-9])\/([0-9][0-9])"
test_str = ("01/01/20\n"
"02/01/20\n"
"03/01/20\n"
"04/01/20\n"
"05/01/20\n"
"06/01/20\n"
"07/01/20\n"
"08/01/20\n"
"09/01/20\n"
"10/01/20\n"
"11/01/20\n"
"12/01/20\n\n"
"01/32/20\n"
"01/03/20\n"
"01/04/20\n"
"01/05/20\n"
"01/06/20\n"
"01/07/20\n"
"01/08/20\n"
"01/09/20\n"
"01/10/20\n"
"01/11/20\n"
"01/12/20\n"
"01/13/20\n"
"01/14/20\n"
"01/15/20\n"
"01/16/20\n"
"01/17/20\n"
"01/18/20\n"
"01/19/20\n"
"01/20/20\n"
"01/21/20\n"
"01/22/20\n"
"01/23/20\n"
"01/24/20\n"
"01/25/20\n"
"01/26/20\n"
"01/27/20\n"
"01/28/20\n"
"01/29/20\n"
"01/30/20\n"
"01/31/20\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.