#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((0|1)[0-9])\/([0-3][0-9])\/([0-9][0-9])"
Local $sString = "01/01/20" & @CRLF & _
"02/01/20" & @CRLF & _
"03/01/20" & @CRLF & _
"04/01/20" & @CRLF & _
"05/01/20" & @CRLF & _
"06/01/20" & @CRLF & _
"07/01/20" & @CRLF & _
"08/01/20" & @CRLF & _
"09/01/20" & @CRLF & _
"10/01/20" & @CRLF & _
"11/01/20" & @CRLF & _
"12/01/20" & @CRLF & _
"" & @CRLF & _
"01/32/20" & @CRLF & _
"01/03/20" & @CRLF & _
"01/04/20" & @CRLF & _
"01/05/20" & @CRLF & _
"01/06/20" & @CRLF & _
"01/07/20" & @CRLF & _
"01/08/20" & @CRLF & _
"01/09/20" & @CRLF & _
"01/10/20" & @CRLF & _
"01/11/20" & @CRLF & _
"01/12/20" & @CRLF & _
"01/13/20" & @CRLF & _
"01/14/20" & @CRLF & _
"01/15/20" & @CRLF & _
"01/16/20" & @CRLF & _
"01/17/20" & @CRLF & _
"01/18/20" & @CRLF & _
"01/19/20" & @CRLF & _
"01/20/20" & @CRLF & _
"01/21/20" & @CRLF & _
"01/22/20" & @CRLF & _
"01/23/20" & @CRLF & _
"01/24/20" & @CRLF & _
"01/25/20" & @CRLF & _
"01/26/20" & @CRLF & _
"01/27/20" & @CRLF & _
"01/28/20" & @CRLF & _
"01/29/20" & @CRLF & _
"01/30/20" & @CRLF & _
"01/31/20" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")