re = /^([a-z0-9_-]+\.)*[a-z0-9_-]+@[a-z0-9_-]+(\.[a-z0-9_-]+)*\.[a-z]{2,6}$/
str = 'yanu12313ari@inbox.ru'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end