package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-z0-9_-]+\.)*[a-z0-9_-]+@[a-z0-9_-]+(\.[a-z0-9_-]+)*\.[a-z]{2,6}$`)
var str = `yanu12313ari@inbox.ru`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}