re = /^select\s+(?<attr>.+?)\s+from\s+(?<name>\S+)\s*(?:where\s+(?<cnd>[\d\w= ><!]+))?;?$/mi
str = 'select * from tab where empno!=zavatra'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end