package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^select\s+(?<attr>.+?)\s+from\s+(?<name>\S+)\s*(?:where\s+(?<cnd>[\d\w= ><!]+))?;?$`)
var str = `select * from tab where empno!=zavatra`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}