$re = '/^\+55[1-9]{2}9[0-9]{8}$/';
$str = '+5511982092205';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);