package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+55[1-9]{2}9[0-9]{8}$`)
var str = `+5511982092205`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}