import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*|(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)";
final String string = "[::1]\n"
+ "[:a:1]\n"
+ "[:bh:lh:1]\n"
+ "[1:1:fEd1:1:abdc:1]\n"
+ "[::ffff:192.0.2.128]\n"
+ "[0000:0000:0000:0000:0000:0000:0000:0001]\n"
+ "[2001:0db8:0000:0000:0000:ff00:0042:8329]\n"
+ "[2001:db8:0:0:0:ff00:42:8329]\n"
+ "[2001:db8::ff00:42:8329]\n"
+ "[2001:0db8:0000:0000:0000:ff00:0042:8329]\n\n"
+ "::1\n"
+ ":a:1\n"
+ ":bh:lh:1\n"
+ "1:1:fEd1:1:abdc:1\n"
+ "::ffff:192.0.2.128\n"
+ "0000:0000:0000:0000:0000:0000:0000:0001\n"
+ "2001:0db8:0000:0000:0000:ff00:0042:8329\n"
+ "2001:db8:0:0:0:ff00:42:8329\n"
+ "2001:db8::ff00:42:8329\n"
+ "2001:0db8:0000:0000:0000:ff00:0042:8329\n\n"
+ "United Kingdom , London\n"
+ "IP: 91.149.202.91\n"
+ "IPv6: 2605:e440:8::2:1b\n"
+ "http://91.149.202.91/1000MB.test\n"
+ "http://[2605:e440:8::2:1b]/1000MB.test\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}