using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*|(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)";
string input = @"[::1]
[:a:1]
[:bh:lh:1]
[1:1:fEd1:1:abdc:1]
[::ffff:192.0.2.128]
[0000:0000:0000:0000:0000:0000:0000:0001]
[2001:0db8:0000:0000:0000:ff00:0042:8329]
[2001:db8:0:0:0:ff00:42:8329]
[2001:db8::ff00:42:8329]
[2001:0db8:0000:0000:0000:ff00:0042:8329]
::1
:a:1
:bh:lh:1
1:1:fEd1:1:abdc:1
::ffff:192.0.2.128
0000:0000:0000:0000:0000:0000:0000:0001
2001:0db8:0000:0000:0000:ff00:0042:8329
2001:db8:0:0:0:ff00:42:8329
2001:db8::ff00:42:8329
2001:0db8:0000:0000:0000:ff00:0042:8329
United Kingdom , London
IP: 91.149.202.91
IPv6: 2605:e440:8::2:1b
http://91.149.202.91/1000MB.test
http://[2605:e440:8::2:1b]/1000MB.test
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}