#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xim)^" & @CRLF & _
"(?P<name>" & @CRLF & _
" (?:(?P<domain>(?:(?:localhost|[\w-]+(?:\.[\w-]+)+)(?::\d+)?)|[\w]+:\d+)/)?" & @CRLF & _
" (?P<image>[a-z0-9_.-]+(?:/[a-z0-9_.-]+)*)" & @CRLF & _
")" & @CRLF & _
"(?::(?P<tag>[\w][\w.-]{0,127}))?" & @CRLF & _
"(?:@(?P<digest>[A-Za-z][A-Za-z0-9]*(?:[+.-_][A-Za-z][A-Za-z0-9]*)*:[0-9a-fA-F]{32,}))?" & @CRLF & _
"$"
Local $sString = "alpine" & @CRLF & _
"alpine:latest" & @CRLF & _
"library/alpine" & @CRLF & _
"localhost/test" & @CRLF & _
"localhost:1234/test" & @CRLF & _
"test:1234/bla" & @CRLF & _
"alpine:3.7" & @CRLF & _
"docker.example.com/gmr/alpine:3.7" & @CRLF & _
"docker.example.com/gmr/alpine/test2:3.7" & @CRLF & _
"docker.example.com/gmr/alpine/test2/test3:3.7" & @CRLF & _
"docker.example.com:5000/gmr/alpine:latest" & @CRLF & _
"docker.example.com:5000/gmr/alpine:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172" & @CRLF & _
"docker.example.com:5000/gmr/alpine/test2:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172" & @CRLF & _
"docker.example.com/gmr/alpine/test2:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172" & @CRLF & _
"docker.example.com/gmr/alpine/test2@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172" & @CRLF & _
"portainer/portainer:latest" & @CRLF & _
"registry:2@sha256:5a156ff125e5a12ac7fdec2b90b7e2ae5120fa249cf62248337b6d04abc574c8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")