const regex = /^(?!\s)(?=\w*[A-Z]\w*[A-Z])(?!\s)(?=\w*[a-z]\w*[a-z])(?=\w*[0-9]\w*[0-9])\w*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\s)(?=\\w*[A-Z]\\w*[A-Z])(?!\\s)(?=\\w*[a-z]\\w*[a-z])(?=\\w*[0-9]\\w*[0-9])\\w*$', '')
const str = `Password_Must_Have_2Cap_2Smal_2num_no_space`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}