#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?!\s)(?=\w*[A-Z]\w*[A-Z])(?!\s)(?=\w*[a-z]\w*[a-z])(?=\w*[0-9]\w*[0-9])\w*$"
Local $sString = "Password_Must_Have_2Cap_2Smal_2num_no_space"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")