# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@(.+?):"
test_str = ("rainyear@hotmail.com:pepper\n"
"rajkomatt3@gmail.com:wehttam12\n"
"rakkasan240b@gmail.com:dn38416\n"
"rallytruckgnome@gmail.com:urban12\n"
"rammer388@gmail.com:ryanm08\n"
"ramonlopezjr@gmail.com:26may2001\n"
"ramsec@live.com:ramseywii1\n"
"randomhulu@gmail.com:moppel12\n"
"rangeman101@hotmail.co.uk:warcraft4\n"
"rangerkid1997@gmail.com:fetherolf5432\n"
"ranglinm@yahoo.com:rang94631\n"
"raphhashem@gmail.com:31951raph\n"
"rappe.austin@gmail.com:Elle4637096\n"
"ratof81@gmail.com:lovecraft1\n"
"raxarraxar@gmail.com:48oakao42\n"
"raylonlong@gmail.com:rayray12\n"
"rayvale.games@googlemail.com:fDbXh87Xfn\n"
"ray_2096@hotmail.com:hardys1996\n"
"rbenade@hotmail.ca:bandstra1\n"
"rcolegreco@gmail.com:Hell0W0rld\n"
"rdfenton@hotmail.com:scoots55\n")
subst = ":"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.