$re = '/^(\S+) (\S+) (\S+) \[[\w:\/]+\s[+-]\d{4}\] (\S+) (\S+) (\S+)\" (\d{3}) [(\d+)|-]/';
$str = '64.242.88.10 - - [07/Mar/2004:16:05:49 -0800] "GET /twiki/bin/edit/Main/Double_bounce_sender?topicparent=Main.ConfigurationVariables HTTP/1.1" 401 -';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);