const regex = /^(\S+) (\S+) (\S+) \[[\w:\/]+\s[+-]\d{4}\] (\S+) (\S+) (\S+)\" (\d{3}) [(\d+)|-]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+) (\\S+) (\\S+) \\[[\\w:\\\/]+\\s[+-]\\d{4}\\] (\\S+) (\\S+) (\\S+)\\" (\\d{3}) [(\\d+)|-]', '')
const str = `64.242.88.10 - - [07/Mar/2004:16:05:49 -0800] "GET /twiki/bin/edit/Main/Double_bounce_sender?topicparent=Main.ConfigurationVariables HTTP/1.1" 401 -`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}