re = /^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$/m
str = '0512345678
05 12 34 56 78
05.12.34.56.78
05-12-34-56-78
+33621325465
+336 21 32 54 65
+336.21.32.54.65
+336-21-32-54-65
0033621325465
00336 21 32 54 65
00336.21.32.54.65
00336-21-32-54-65'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end