#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$"
Local $sString = "0512345678" & @CRLF & _
"05 12 34 56 78" & @CRLF & _
"05.12.34.56.78" & @CRLF & _
"05-12-34-56-78" & @CRLF & _
"+33621325465" & @CRLF & _
"+336 21 32 54 65" & @CRLF & _
"+336.21.32.54.65" & @CRLF & _
"+336-21-32-54-65" & @CRLF & _
"0033621325465" & @CRLF & _
"00336 21 32 54 65" & @CRLF & _
"00336.21.32.54.65" & @CRLF & _
"00336-21-32-54-65"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")