const regex = new RegExp('\\d+\\s(.+)\\s\\d+\\s\\w+', '')
const str = `12 RUE DE LA MORT 75016 PARIS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}