package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\s(.+)\s\d+\s\w+`)
var str = `12 RUE DE LA MORT 75016 PARIS`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}