import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^.*\\s([^:,\\s]+):\\s+([^:\\n]+)|\\G(?!\\A))\\s*at\\s+(\\S+)\\((\\w+\\.\\w+):(\\d+)\\)$";
final String string = "my error java.lang.NullPointerException: Sample Java Logback Exception\n"
+ "at Sample.errorLevel3(Sample.java:35)\n"
+ "at Sample.errorLevel2(Sample.java:31)\n"
+ "at Sample.errorLevel1(Sample.java:27)\n"
+ "at Sample.main(Sample.java:15)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}