#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^.*\s([^:,\s]+):\s+([^:\n]+)|\G(?!\A))\s*at\s+(\S+)\((\w+\.\w+):(\d+)\)$"
Local $sString = "my error java.lang.NullPointerException: Sample Java Logback Exception" & @CRLF & _
"at Sample.errorLevel3(Sample.java:35)" & @CRLF & _
"at Sample.errorLevel2(Sample.java:31)" & @CRLF & _
"at Sample.errorLevel1(Sample.java:27)" & @CRLF & _
"at Sample.main(Sample.java:15)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")