import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bfunction\\s+(\\w+)\\([^()]*\\)\\s*\\{|(?!^\\G))(?:(?!\\bfunction\\s+\\w+\\([^()]*\\)\\s+\\{|\\}\\h*\\r?\\n).)*?\\$body\\s*->\\s*(\\w+)|function\\s*(.+?)\\(";
final String string = "function deviceUpdate($body)\n"
+ " { \n"
+ " \n"
+ " }\n"
+ " \n"
+ "function postad($body)\n"
+ " {\n"
+ " \n"
+ " $adtitle = $body -> adtitle;\n"
+ " $addescription = $body -> addescription;\n"
+ " \n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}