#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:\bfunction\s+(\w+)\([^()]*\)\s*\{|(?!^\G))(?:(?!\bfunction\s+\w+\([^()]*\)\s+{|}\h*\r?\n).)*?\$body\s*->\s*(\w+)|function\s*(.+?)\("
Local $sString = "function deviceUpdate($body)" & @CRLF & _
" { " & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
"function postad($body)" & @CRLF & _
" {" & @CRLF & _
" " & @CRLF & _
" $adtitle = $body -> adtitle;" & @CRLF & _
" $addescription = $body -> addescription;" & @CRLF & _
" " & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")