re = /^(https?:\/\/|)(.*?)(\/.*|)$/m
str = 'example.com
example.com/poooj
http://example.com/
http://example.com
https://example.com/dddeef
http://example.com/?
http://example.com//'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end