$re = '/^(https?:\/\/|)(.*?)(\/.*|)$/m';
$str = 'example.com
example.com/poooj
http://example.com/
http://example.com
https://example.com/dddeef
http://example.com/?
http://example.com//';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);