import Foundation
let pattern = #"(.*)(-)(.*)(-)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10-10-2017
10-10-2017
10-10-2017
10-1-2018
10-1-2018
10-1-2018
10-1-2018
10-1-2018
10-1-2018
10-2-2018
10-2-2018
10-2-2018
10-3-2018
10-3-2018
10-7-2017
10-7-2017
10-7-2017
10-7-2017
10-7-2017
10-7-2017
10-7-2017
10-8-2017
10-8-2017
10-8-2017
10-8-2017
10-9-2017
10-9-2017
1-10-2017
1-10-2017
1-10-2017
1-10-2017
11-10-2017
11-10-2017
11-11-2017
11-11-2017
11-11-2017
11-11-2017
1-112017
1-11-2017
1-11-2017
1-11-2017
1-11-2017
1-11-2017
11-1-2018
11-1-2018
11-1-2018
11-1-2018
1-1-2017
1-1-2018
1-1-2018
1-1-2018
11-2-2018
11-2-2018
11-2-2018
11-7-2017
12-11-2017
1-2-2018
1-2-2018
1-2-2018
1-2-2018
12-2-2018
12-2-2018
12-2-2018
12-2-2018
12-2-2018
12-2-2018
12-3-2018
12-3-2018
12-3-2018
12-3-2018
12-3-2018
12-3-2018
12-3-2018
12-7-2017
12-7-2017
12-7-2017
12-7-2017
12-7-2017
12-7-2017
12-7-2017
12-9-2017
13-11-2017
13-11-2017
13-11-2017
13-1-2018
13-1-2018
13-1-2018
1-3-2018
1-3-2018
13-6-2017
13-7-2017
13-7-2017
13-7-2017
13-7-2017
13-7-2017
13-7-2017
13-7-2017
13-8-2017
13-8-2017
13-8-2017
13-8-2017
13-8-2017
13-9-2017
13-9-2017
13-9-2017
14-10-2017
14-10-2017
14-10-2017
14-11-2017
14-11-2017
14-11-2017
14-1-2018
14-1-2018
1-4-2018
1-4-2018
1-4-2018
14-2-2018
14-3-2018
14-3-2018
14-3-2018
14-3-2018
14-3-2018
14-3-2018
14-7-2017
14-8-2017
14-8-2017
14-8-2017
15-10-2017
15-10-2017
15-11-2017
15-11-2017
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-1-2018
15-2-2018
15-2-2018
15-2-2018
15-2-2018
15-3-2018
15-3-2018
15-7-2017
15-7-2017
15-7-2017
15-7-2017
15-7-2017
16-10-2017
16-10-2017
16-10-2017
16-10-2017
16-11-2017
16-11-2017
16-11-2017
16-11-2017
16-1-2018
16-7-2017
16-7-2017
16-7-2017
16-8-2017
16-8-2017
16-9-2017
16-9-2017
16-9-2017
16-9-2017
16-9-2017
17-10-2017
17-10-2017
17-10-2017
17-11-2017
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-1-2018
17-2-2018
17-2-2018
17-2-2018
17-3-2018
17-3-2018
17-3-2018
17-7-2017
17-7-2017
17-7-2017
17-7-2017
17-7-2017
17-7-2017
17-9-2017
17-9-2017
17-9-2017
18-10-2017
18-10-2017
18-10-2017
18-10-2017
18-10-2017
18-11-2017
18-11-2017
18-1-2018
18-1-2018
18-1-2018
18-1-2018
18-1-2018
1-8-2017
1-8-2017
1-8-2017
1-8-2017
18-2-2018
18-3-2018
18-3-2018
18-3-2018
18-7-2017
18-7-2017
18-7-2017
18-7-2017
18-7-2017
18-7-2017
18-9-2017
19-10-2017
19-10-2017
19-10-2017
19-10-2017
19-10-2017
19-11-2017
19-11-2017
19-2-2018
19-2-2018
19-2-2018
19-3-2018
19-3-2018
19-3-2018
19-3-2018
19-3-2018
19-3-2018
19-8-2017
19-8-2017
19-8-2017
19-8-2017
20-1-2018
20-1-2018
20-1-2018
20-1-2018
20-1-2018
20-1-2018
20-1-2018
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\5\4\3\2\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)