#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(-)(.*)(-)(.*)"
Local $sString = "10-10-2017" & @CRLF & _
"10-10-2017" & @CRLF & _
"10-10-2017" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-1-2018" & @CRLF & _
"10-2-2018" & @CRLF & _
"10-2-2018" & @CRLF & _
"10-2-2018" & @CRLF & _
"10-3-2018" & @CRLF & _
"10-3-2018" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-7-2017" & @CRLF & _
"10-8-2017" & @CRLF & _
"10-8-2017" & @CRLF & _
"10-8-2017" & @CRLF & _
"10-8-2017" & @CRLF & _
"10-9-2017" & @CRLF & _
"10-9-2017" & @CRLF & _
"1-10-2017" & @CRLF & _
"1-10-2017" & @CRLF & _
"1-10-2017" & @CRLF & _
"1-10-2017" & @CRLF & _
"11-10-2017" & @CRLF & _
"11-10-2017" & @CRLF & _
"11-11-2017" & @CRLF & _
"11-11-2017" & @CRLF & _
"11-11-2017" & @CRLF & _
"11-11-2017" & @CRLF & _
"1-112017" & @CRLF & _
"1-11-2017" & @CRLF & _
"1-11-2017" & @CRLF & _
"1-11-2017" & @CRLF & _
"1-11-2017" & @CRLF & _
"1-11-2017" & @CRLF & _
"11-1-2018" & @CRLF & _
"11-1-2018" & @CRLF & _
"11-1-2018" & @CRLF & _
"11-1-2018" & @CRLF & _
"1-1-2017" & @CRLF & _
"1-1-2018" & @CRLF & _
"1-1-2018" & @CRLF & _
"1-1-2018" & @CRLF & _
"11-2-2018" & @CRLF & _
"11-2-2018" & @CRLF & _
"11-2-2018" & @CRLF & _
"11-7-2017" & @CRLF & _
"12-11-2017" & @CRLF & _
"1-2-2018" & @CRLF & _
"1-2-2018" & @CRLF & _
"1-2-2018" & @CRLF & _
"1-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-2-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-3-2018" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-7-2017" & @CRLF & _
"12-9-2017" & @CRLF & _
"13-11-2017" & @CRLF & _
"13-11-2017" & @CRLF & _
"13-11-2017" & @CRLF & _
"13-1-2018" & @CRLF & _
"13-1-2018" & @CRLF & _
"13-1-2018" & @CRLF & _
"1-3-2018" & @CRLF & _
"1-3-2018" & @CRLF & _
"13-6-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-7-2017" & @CRLF & _
"13-8-2017" & @CRLF & _
"13-8-2017" & @CRLF & _
"13-8-2017" & @CRLF & _
"13-8-2017" & @CRLF & _
"13-8-2017" & @CRLF & _
"13-9-2017" & @CRLF & _
"13-9-2017" & @CRLF & _
"13-9-2017" & @CRLF & _
"14-10-2017" & @CRLF & _
"14-10-2017" & @CRLF & _
"14-10-2017" & @CRLF & _
"14-11-2017" & @CRLF & _
"14-11-2017" & @CRLF & _
"14-11-2017" & @CRLF & _
"14-1-2018" & @CRLF & _
"14-1-2018" & @CRLF & _
"1-4-2018" & @CRLF & _
"1-4-2018" & @CRLF & _
"1-4-2018" & @CRLF & _
"14-2-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-3-2018" & @CRLF & _
"14-7-2017" & @CRLF & _
"14-8-2017" & @CRLF & _
"14-8-2017" & @CRLF & _
"14-8-2017" & @CRLF & _
"15-10-2017" & @CRLF & _
"15-10-2017" & @CRLF & _
"15-11-2017" & @CRLF & _
"15-11-2017" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-1-2018" & @CRLF & _
"15-2-2018" & @CRLF & _
"15-2-2018" & @CRLF & _
"15-2-2018" & @CRLF & _
"15-2-2018" & @CRLF & _
"15-3-2018" & @CRLF & _
"15-3-2018" & @CRLF & _
"15-7-2017" & @CRLF & _
"15-7-2017" & @CRLF & _
"15-7-2017" & @CRLF & _
"15-7-2017" & @CRLF & _
"15-7-2017" & @CRLF & _
"16-10-2017" & @CRLF & _
"16-10-2017" & @CRLF & _
"16-10-2017" & @CRLF & _
"16-10-2017" & @CRLF & _
"16-11-2017" & @CRLF & _
"16-11-2017" & @CRLF & _
"16-11-2017" & @CRLF & _
"16-11-2017" & @CRLF & _
"16-1-2018" & @CRLF & _
"16-7-2017" & @CRLF & _
"16-7-2017" & @CRLF & _
"16-7-2017" & @CRLF & _
"16-8-2017" & @CRLF & _
"16-8-2017" & @CRLF & _
"16-9-2017" & @CRLF & _
"16-9-2017" & @CRLF & _
"16-9-2017" & @CRLF & _
"16-9-2017" & @CRLF & _
"16-9-2017" & @CRLF & _
"17-10-2017" & @CRLF & _
"17-10-2017" & @CRLF & _
"17-10-2017" & @CRLF & _
"17-11-2017" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-1-2018" & @CRLF & _
"17-2-2018" & @CRLF & _
"17-2-2018" & @CRLF & _
"17-2-2018" & @CRLF & _
"17-3-2018" & @CRLF & _
"17-3-2018" & @CRLF & _
"17-3-2018" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-7-2017" & @CRLF & _
"17-9-2017" & @CRLF & _
"17-9-2017" & @CRLF & _
"17-9-2017" & @CRLF & _
"18-10-2017" & @CRLF & _
"18-10-2017" & @CRLF & _
"18-10-2017" & @CRLF & _
"18-10-2017" & @CRLF & _
"18-10-2017" & @CRLF & _
"18-11-2017" & @CRLF & _
"18-11-2017" & @CRLF & _
"18-1-2018" & @CRLF & _
"18-1-2018" & @CRLF & _
"18-1-2018" & @CRLF & _
"18-1-2018" & @CRLF & _
"18-1-2018" & @CRLF & _
"1-8-2017" & @CRLF & _
"1-8-2017" & @CRLF & _
"1-8-2017" & @CRLF & _
"1-8-2017" & @CRLF & _
"18-2-2018" & @CRLF & _
"18-3-2018" & @CRLF & _
"18-3-2018" & @CRLF & _
"18-3-2018" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-7-2017" & @CRLF & _
"18-9-2017" & @CRLF & _
"19-10-2017" & @CRLF & _
"19-10-2017" & @CRLF & _
"19-10-2017" & @CRLF & _
"19-10-2017" & @CRLF & _
"19-10-2017" & @CRLF & _
"19-11-2017" & @CRLF & _
"19-11-2017" & @CRLF & _
"19-2-2018" & @CRLF & _
"19-2-2018" & @CRLF & _
"19-2-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-3-2018" & @CRLF & _
"19-8-2017" & @CRLF & _
"19-8-2017" & @CRLF & _
"19-8-2017" & @CRLF & _
"19-8-2017" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
"20-1-2018" & @CRLF & _
""
Local $sSubst = "\5\4\3\2\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)