const regex = /.*http:.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*http:.*', '')
const str = `//this line should be ignored http://foo.com
NSString *url = @"http://foo.com"; //this line should show up as a result`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}