package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*http:.*`)
var str = `//this line should be ignored http://foo.com
NSString *url = @"http://foo.com"; //this line should show up as a result`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}