const regex = /(^|\b|\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)($|\b|\W)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\b|\\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)($|\\b|\\W)', 'g')
const str = `putá el que lo lea putaaaááÁÁaaaa:puta🍕. hijo-de-puuta: Esto es una putada. pupupuputa puto
Pu7äs every where.PUTAPuTAaaa-PûTA. Había unos cuantos hijos de puutaááaaó puta
lalal putaaa7 que te put@sñññ que (puta) eres. puta puta puta
Reputados réputaçión -> la é y la ç son \\W
Padre putativo
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}