package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\b|\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)($|\b|\W)`)
var str = `putá el que lo lea putaaaááÁÁaaaa:puta 🍕. hijo-de-puuta: Esto es una putada. pupupuputa puto
Pu7äs every where.PUTAPuTAaaa-PûTA. Había unos cuantos hijos de puutaááaaó puta
lalal putaaa7 que te put@sñññ que (puta) eres. puta puta puta
Reputados réputaçión -> la é y la ç son \W
Padre putativo
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}