// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[code][^\[]*\[\/code]").unwrap();
let string = "hi how are you [code]a=b+c[/code] again some text[code]c= 7*5[/code] Now some text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}