$re = '/\[code][^\[]*\[\/code]/m';
$str = 'hi how are you [code]a=b+c[/code] again some text[code]c= 7*5[/code] Now some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);