re = /(?:^(?:[a-zA-Z0-9]|[a-zA-Z0-9][\w-]*[a-zA-Z0-9])\/(?:[a-zA-Z0-9]|[a-zA-Z0-9][\w-]*[a-zA-Z0-9]|\+)$)|^(?:\+\/\+)$/
str = 'abcdefghijklmnopqrstuvwxyz/0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end