package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^(?:[a-zA-Z0-9]|[a-zA-Z0-9][\w-]*[a-zA-Z0-9])\/(?:[a-zA-Z0-9]|[a-zA-Z0-9][\w-]*[a-zA-Z0-9]|\+)$)|^(?:\+\/\+)$`)
var str = `abcdefghijklmnopqrstuvwxyz/0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}