$re = '/[A-Z0-9]*/';
$str = '1B721D79824245FF8BB625486DEDE092';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);