package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z0-9]*`)
var str = `1B721D79824245FF8BB625486DEDE092`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}