import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n\\r\\0]*(?=\\w)(.*)";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. \n"
+ " Mauris aliquet malesuada feugiat. Curabitur fermentum \n"
+ " bibendum nulla, non dictum ipsum tincidunt non. Quisque \n"
+ " convallis pharetra tempor. Vivamus vehicula dignissim augue et \n"
+ " scelerisque. Etiam quam nisi, molestie ac dolor in, \n"
+ " tincidunt tincidunt arcu. Praesent sed justo finibus, \n"
+ " fringilla velit quis, porta erat. Donec blandit metus ut \n"
+ " arcu iaculis iaculis. Cras nec dolor fringilla justo \n"
+ " ullamcorper auctor. Aliquam eget pretium velit. Morbi urna \n"
+ " justo, pulvinar id lobortis in, aliquet placerat orci.";
final String subst = "<p>$1</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}