re = /\b(?:loan)\s*(?:balance|amounts?|reimbursements?|installments?)?\s*(?:of|is|\s|\:|\-)\s*(?:(?:[\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$)?)|(?:[\.\,\d]+\s*(?:\$)))|(?: [\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$ ))|(?:[\.\,\d]+\s*(?:\$ ))/mi
str = 'loan balance is $45,56.89
loan balance of $ 1M
Loan Amount of 43000K
loan reimbursement is 54.4 dollars
loan reimbursement is 34,10.45 million
loan balance of 25000$
loan amount $100,200.30
Loan Amount: 100K
Loan Amount $ 1.5 million
loan is $54K
loan balance - 50K$
----------------------------------------------------------------
2.9 millions
$25000.50
1,99$
$25000
1.10 dollar $25000
1,99 dollars $23K
$ 25,00
1.10 dollar $25,000.50
1,99 dollars $25000.50
10 dollar
$ 25,000
1.99$
1,99$
$25000
1.10 dollar $25000.50
1,99 dollars
10 dollar
$ 25,000
25,000.50$
1.99$
$25,000.50
1.10 dollar $25000.50
1,99 dollars $23K
10 dollar $25000
1.99$
$ 25,000
djkb_09$kjh87
gh67_($67.67P)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end